pod install時にoffline or github is downなどと言われるのを修正

たまにあるみたいなので、自分の直し方を書く。

原因はopensslが古いため(っぽい)

とりあえず、まずはこれを打ちましょう。

xcode-select –install

まず、systemのrubyを使うのはやめて、rvmを入れましょう。また、homebrewのインストールは前提です。

そのあとは、rubyインストールしましょう。もしすでにインストール済みであれば、reinstallで同じバージョンを入れ直してください。

その段階で、ほぼ治っているはずです。もう一度、pod installを走らせます。必要に応じて、pod repo updateする必要があるかもしれません。

おそらく、SSL接続でエラー出てるような挙動なので(ちゃんとトラッキングしてませんが)、この治し方はそこまで的外れではないかなという気がします。もし遭遇したら試してみてください。

Leave a Reply

Your email address will not be published. Required fields are marked *