EclipseにLombokを対応させる

TL;DR

IntelliJ + Lombok Pluginを使いましょう!(爆)


それでもeclipseを使う人向けに、以下、簡単にやり方紹介します。

ひとまず、lombok.jarをダウンロードしましょう。

https://projectlombok.org/download

こちらからダウンロードしたら、ダブルクリックで開きます。こんな画面が出ます。

最新のeclipseをインストールした状態だと、デフォルトでeclipseが見つからなかったので、自分で追加します。specify location…をクリックしてください。

そして、インストールしたeclipseの中にeclipse.iniがあるのでそれを指定します。

ここ意外と、ハマると思うので、気をつけてください。eclipseのバイナリを指定しても動きません。

そうしたら、install/updateをクリックしてinstallを完了させてください。

自分のプロジェクトではmavenをビルドツールとして使っていたので、eclipseを再起動させた後、Project rootをright-click->Maven->Update Project… をすると、エラーが消えると思います。

Leave a Reply

Your email address will not be published. Required fields are marked *